Перейти к содержимому



Траблы


Ответов в теме: 7

#1 Pibl

    Стрелок

  • Помощник шерифаПомощники шерифа
  • 1 662 сообщений
  • Из: г. Озёрск Челябинской области

Отправлено: 01 Июль 2002 - 11:42:41

ged! У меня возникают небольшие траблы при написании слова на каком-либо языке, отличном от русского и английского... Например, я копирую название песни из Windows Media Player (а там при распознании CD частенько названия трэков написаны на родном исполнителю языке), вставляю в свою мессагу - всё зашибись... Отправляю, и вижу вместо своих умных  ;D мыслей  ;D одну тарабарщину... Причём всё написанное уже не восстановить, если бы не Punto Switcher и его дневник... Траблы, конечно небольшие, но всё-равно... Интересно, чегой-то так?!

Now Playing: Doc Martin & Tony Hewitt 'Left Cost Cell'
Я атеист и не верю ни во что и никому. Но я остерегаюсь навязывать свое мнение кому-нибудь другому, я не вправе кого-либо судить. Hein Frode from «Theatre Of Tragedy»

Изображение

#2 ged

    Стрелок

  • ШерифШериф
  • 2 562 сообщений
  • Пол: м
  • Из: Россия

Отправлено: 02 Июль 2002 - 09:35:27

Я думаю проблема в следующем:
когда ты набиваешь текст в браузере он считает что текст набивается в определенной кодировке - для русскоязычных стран Win1251 и KOI8-R под один символ в данных кодировках выделяется 1 байт. Когда ты копируешь текст из Windows Media Player'a то текст этот копируется в кодировке Unicode (2 байта на 1 символ). Браузер понимает Unicode и корректно его отображает и передает в запросе сайту, когда сообщение сохраняется. Но скрипты форума считают что 1 символ кодируется 1 байтом, а не двумя, поэтому пришедшее сообщение и сохраняется в форуме в искореженном виде.

выход один - не копировать текст из Windows Media Player'a  ;)
Изображение Изображение

#3 Pibl

    Стрелок

  • Помощник шерифаПомощники шерифа
  • 1 662 сообщений
  • Из: г. Озёрск Челябинской области

Отправлено: 02 Июль 2002 - 12:52:18

Цитата

Я думаю проблема в следующем:
когда ты набиваешь текст в браузере он считает что текст набивается в определенной кодировке - для русскоязычных стран Win1251 и KOI8-R под один символ в данных кодировках выделяется 1 байт. Когда ты копируешь текст из Windows Media Player'a то текст этот копируется в кодировке Unicode (2 байта на 1 символ). Браузер понимает Unicode и корректно его отображает и передает в запросе сайту, когда сообщение сохраняется. Но скрипты форума считают что 1 символ кодируется 1 байтом, а не двумя, поэтому пришедшее сообщение и сохраняется в форуме в искореженном виде.

выход один - не копировать текст из Windows Media Player'a  ;)

О-о-о... Сколько умных слов, однако... Хорошо хоть вывод сделал... ;)

Now Playing: Metallica 'Better Than You'

PS Хотя всё равно не всё понятно... Взять, например, название, которое я сейчас вставил из WMP - оно на английском, и всё будет зачипок, а стоит вставить название на любом языке окромя англицкого или великого и могучего, как... ;)
Я атеист и не верю ни во что и никому. Но я остерегаюсь навязывать свое мнение кому-нибудь другому, я не вправе кого-либо судить. Hein Frode from «Theatre Of Tragedy»

Изображение

#4 ged

    Стрелок

  • ШерифШериф
  • 2 562 сообщений
  • Пол: м
  • Из: Россия

Отправлено: 02 Июль 2002 - 13:41:31

;)
А фиг его знает как Explorer (или что ты там юзаешь) разбирается с разными кодировками на своем уровне при копировании Copy/Paste ;) Может он распознает установленные в системе языки (любимый переключатель En/Ru) и в подобном случае не использует unicode  ???... в общем точно не знаю.
Изображение Изображение

#5 Rok2y

    Ученик

  • Пользователи
  • **
  • 98 сообщений
  • Из: Россия

Отправлено: 22 Сентябрь 2002 - 22:19:58

а почему форум так медленно работает?
ну я имею ввиду по сравнению с другими
и может избавиться от смайликов шоб не засорять

#6 Vjacheslav

    всегда в дороге

  • Помощник шерифаПомощники шерифа
  • 755 сообщений
  • Из: Ногинск, Россия

Отправлено: 23 Сентябрь 2002 - 07:50:08

Это не форум медленно работает. Может быть пропускная способность линии такая. У меня, например, все работает как с винчестера.

#7 galden

    Подмастерье

  • Пользователи
  • ***
  • 169 сообщений
  • Из: Уфа

Отправлено: 27 Май 2004 - 09:48:54

Может уже было, но все же:
1. Когда отвечаешь, неужели обязательно выводить при этом все сообщения топика внизу, может ограничиться 10-ю последними. Представляю, как иногда мучаются владельцы dial-up.
2. Такой баг: при обновлении открытой странички, где идет обсуждение ТБ-6, если до этого отправлялся какой-нить комментарийй, он рисуется снова (может, кто-то уже заметил, когда мой выплевывался несколько раз).

#8 ged

    Стрелок

  • ШерифШериф
  • 2 562 сообщений
  • Пол: м
  • Из: Россия

Отправлено: 27 Май 2004 - 10:19:53

Цитата

Может уже было, но все же:
1. Когда отвечаешь, неужели обязательно выводить при этом все сообщения топика внизу, может ограничиться 10-ю последними. Представляю, как иногда мучаются владельцы dial-up.

Здесь ниче не поделаешь, нету у меня никакого желания лезть в исходники форума.

Цитата

2. Такой баг: при обновлении открытой странички, где идет обсуждение ТБ-6, если до этого отправлялся какой-нить комментарийй, он рисуется снова (может, кто-то уже заметил, когда мой выплевывался несколько раз).

Знаю :D... надо будет пофиксить
Изображение Изображение





ИСПОЛЬЗОВАНИЕ МАТЕРИАЛОВ САЙТА ВОЗМОЖНО ТОЛЬКО С РАЗРЕШЕНИЯ АВТОРОВ И УКАЗАНИЯ ССЫЛКИ НА САЙТ Стивен Кинг.ру - Творчество Стивена Кинга!
ЗАМЕТИЛИ ОШИБКУ? Напишите нам об этом!
Яндекс.Метрика